GUIDELINE TO
CAPTURING WETLAND BOUNDARIES
FROM SATELLITE IMAGERY

Dr. Heidi van Deventer
GIS/RS Research at the Council for Scientific & Industrial Research (CSIR)

For the
2016 Freshwater Ecosystem Network
training day

Version:
12 July 2016

This manual may be freely distributed.
CONTENTS

GUIDELINE TO ........................................................................................................ 1
CAPTURING WETLAND BOUNDARIES ..................................................................... 1
FROM SATELLITE IMAGERY ..................................................................................... 1
CONTENTS .................................................................................................................. 1
ACRONYMS .................................................................................................................. 2

SECTION 1: WETLANDS DATA CAPTURING USE USING GEOGRAPHICAL INFORMATION SYSTEMS ................................................................................................................. 3

1.1 INTRODUCTION .................................................................................................... 3
1.2 ANCILLARY DATA TO USE FOR ORIENTATION .................................................. 3

SECTION 2: HOW TO CAPTURE GEOSPATIAL DATA FROM SATELLITE IMAGERY USING QGIS5

2.1 INSTALLING QUANTUM GIS (QGIS) (FREEWARE) ........................................... 5
   Step 1: Download and install QGIS ........................................................................ 5
   Step 2: Open QGIS and start a new project .......................................................... 5
   Step 3: Add data to your project .......................................................................... 7
   Step 4: Install plugins .......................................................................................... 10
   Step 5: Browsing through the data ...................................................................... 11
   Step 6: Creating a new layer, copying features and adding an attribute field ........ 11
   Step 7: Capture a polygon ................................................................................... 13
   Step 8: Deleting a polygon .................................................................................. 14
   Step 9: Reshaping a polygon ............................................................................... 14
   Step 10: Capturing adjacent polygons ................................................................ 15
   Step 11: Splitting a polygon ............................................................................... 16
   Step 12: Merging adjacent polygons ................................................................... 17
   Step 13: Using ancillary data to verify HGM types ............................................. 17
   Step 14. Creating a DEM and calculating slope ................................................... 19
   Step 15. Other useful tools: Tracing an existing polygon ..................................... 21
   Step 16. Calculating surface area and central coordinates ................................... 21
   Step 17. Checking and correcting topology ......................................................... 22
   Step 18. Making a map ....................................................................................... 23

CONCLUSION ............................................................................................................. 24
ACRONYMS

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARC</td>
<td>Agricultural Research Council</td>
</tr>
<tr>
<td>DEA</td>
<td>Department of Environmental Affairs</td>
</tr>
<tr>
<td>DEM</td>
<td>Digital Elevation Model</td>
</tr>
<tr>
<td>DRDLR</td>
<td>Department of Rural Development and Land Reform, Directorate National GeoInformation</td>
</tr>
<tr>
<td>NGI</td>
<td>GeoInformation</td>
</tr>
<tr>
<td>DWS</td>
<td>Department of Water and Sanitation</td>
</tr>
<tr>
<td>ESRI</td>
<td>Environmental Systems Research Institute</td>
</tr>
<tr>
<td>GIS</td>
<td>Geographic Information System</td>
</tr>
<tr>
<td>KZN</td>
<td>KwaZulu-Natal</td>
</tr>
<tr>
<td>MDB</td>
<td>Municipal Demarcation Board</td>
</tr>
<tr>
<td>QGIS</td>
<td>Quantum GIS</td>
</tr>
<tr>
<td>SANBI</td>
<td>South African National Biodiversity Institute</td>
</tr>
<tr>
<td>SANSA</td>
<td>South African National Space Agency</td>
</tr>
<tr>
<td>SRTM</td>
<td>Shuttle Radar Topography Mapper</td>
</tr>
<tr>
<td>WGS84</td>
<td>World Geodetic System of 1984</td>
</tr>
<tr>
<td>WMS</td>
<td>Web Map Service</td>
</tr>
</tbody>
</table>

1 Former Department of Land Affairs (DLA), Chief Directorate of Surveys & Mapping (CD:SM)
SECTION 1: WETLANDS DATA CAPTURING USE USING GEOGRAPHICAL INFORMATION SYSTEMS

1.1 INTRODUCTION

This guideline was compiled by Heidi van Deventer for a training session at the Freshwater Ecosystems Network meeting on 12 July 2016.

The guideline may be freely distributed to anyone who is willing to map and contribute data related to freshwater ecosystems, such as wetlands, to the National Freshwater Inventory hosted by South African National Biodiversity Institute (SANBI).

The aim of the guidelines is to provide training on how Geographical Information Systems (GIS) packages, such as QGIS or ArcGIS software, can be used for capturing, classification and editing of wetland boundaries. The guideline is divided into three Sections as follows:

Section 1: Where to find useful orientation data and free satellite images when digitising wetlands
Section 2: demonstrates techniques for capturing, classification and editing of wetland polygons in Quantum GIS (QGIS).

1.2. ANCILLARY DATA TO USE FOR ORIENTATION

A number of data sets are useful in capturing and updating the wetland boundaries, including image data sets (Table 1) and vector data (Table 2).

Image data sources can be obtained either as mosaics of individual tiles, or as the original images with the four bands red, green, blue (RGB) and infrared bands.

Table 1: Image data sources for heads-up digitising of wetland boundaries.

<table>
<thead>
<tr>
<th>Data set name</th>
<th>Spatial resolution</th>
<th>Scale</th>
<th>Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orthophotography (greyscale, historic)</td>
<td>0.75 m</td>
<td>1:10 000</td>
<td>DRDLR</td>
<td>Orthophotos are aerial photos which are geometrically corrected and georeferenced to a uniform scale.</td>
</tr>
<tr>
<td>Colour orthophotography</td>
<td>0.5 m</td>
<td>1:10 000</td>
<td>DRDLR</td>
<td>More recently captured since 2008</td>
</tr>
<tr>
<td>SPOT</td>
<td>2.5 m</td>
<td>(Unknown)</td>
<td>SANSA</td>
<td>SPOT mosaic for study area provided by SANSA as the 2011 mosaic version.</td>
</tr>
</tbody>
</table>

Data from the sub-quaternary catchment around Wakkerstroom in the Mpumalanga Province are used in this guideline as a case study to show how data can be captured, updated and verified.
Table 2: Ancillary data that can be useful when capturing wetland boundaries.

<table>
<thead>
<tr>
<th>Data set name</th>
<th>Data type:</th>
<th>Scale</th>
<th>Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catchment boundaries</td>
<td>Polygons</td>
<td>DWA/DWS, 2012</td>
<td>DWA/DWS,</td>
<td>Primary, secondary, tertiary and quaternary catchment data.</td>
</tr>
<tr>
<td>Contour lines</td>
<td>Lines</td>
<td>1:10 000</td>
<td>DRLR-NGI</td>
<td>The 5 m interval contours can be used to indicate change in terrain or calculate slope.</td>
</tr>
<tr>
<td>Grid references</td>
<td>Polygons</td>
<td>1:50 000</td>
<td>DRDLR</td>
<td>The boundary lines of the 1:10 000 orthophotos and 1:50 000 topographical maps.</td>
</tr>
<tr>
<td>Hydrological data from the DRDLR-NGI</td>
<td>Points,</td>
<td>Vary</td>
<td>DRDLR-NGI</td>
<td>Springs (points), river lines 1:50 000 and wetland polygons at 1:50 000 (various categories are used including marsh, vlei, rivers, pans and mudflats) can be obtained as provincial geodatabases (exported from Geomedia).</td>
</tr>
<tr>
<td></td>
<td>lines and polygons</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Large dams and rivers</td>
<td>Polygons</td>
<td>1:50 000</td>
<td>DWA/DWS</td>
<td>Large dams and rivers mapped at 1:50 000 scale.</td>
</tr>
<tr>
<td></td>
<td>lines</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Land cover 2014</td>
<td></td>
<td>1:50 000</td>
<td>DEA</td>
<td>Wetland delineation map classified as natural or artificial. Estuaries were removed and the remainder classified for wetland typing purposes for the freshwater conservation plan and priorities. Download from SANBI's BGIS website. This product is currently being updated as part of the next National Biodiversity Assessment for 2018.</td>
</tr>
<tr>
<td>National Wetland Map (NWM) v.4</td>
<td>Polygons</td>
<td>1:10 000 –</td>
<td>SANBI, 2011</td>
<td>Wetland delineation map classified as natural or artificial. Estuaries were removed and the remainder classified for wetland typing purposes for the freshwater conservation plan and priorities. Download from SANBI's BGIS website. This product is currently being updated as part of the next National Biodiversity Assessment for 2018.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1:50 000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peatlands</td>
<td>Points /</td>
<td>Unknown</td>
<td>WRC</td>
<td>National Peatland Database (WRC project K5/2346)</td>
</tr>
<tr>
<td></td>
<td>polygons</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Political boundaries (provincial,</td>
<td>Polygons</td>
<td>vary</td>
<td>MDB</td>
<td>Political boundaries to use for orientation purposes.</td>
</tr>
<tr>
<td>district, local and ward boundaries)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protected areas</td>
<td>Polygons</td>
<td>unknown</td>
<td>SANBI, 2010</td>
<td>Formal protected areas.</td>
</tr>
<tr>
<td>SPOT heights</td>
<td>Points</td>
<td>1:10 000</td>
<td>DRLR-NGI</td>
<td>The spot heights can indicate terrain and can be used to calculate a DEM and to derive slope.</td>
</tr>
<tr>
<td>Sub-quaternary catchments</td>
<td>Polygons</td>
<td>NFEPA</td>
<td></td>
<td>ATLAS of Freshwater Ecosystem Priority Areas in South Africa: Maps to support sustainable development of water resources Atlas and data (DVD) can be obtained from the WRC or data can be downloaded from SANBI's BGIS website.</td>
</tr>
<tr>
<td>Topographical data from topographical maps*</td>
<td>Various (polygons, lines and points)</td>
<td>1:50 000</td>
<td>DRDLR</td>
<td>River lines, river areas, water bodies (small dams), railway lines, railway stations, roads.</td>
</tr>
</tbody>
</table>
SECTION 2: HOW TO CAPTURE GEOSPATIAL DATA FROM SATELLITE IMAGERY USING QGIS

2.1. INSTALLING QUANTUM GIS (QGIS) (FREEWARE)

Step 1: Download and install QGIS

The QGIS installation file can be obtained from http://www.qgis.co.za/

QGIS is freeware and may be downloaded and installed without costs involved. Select the QGIS Standalone Installer for a 32 bit or 64 bit machine – depending on your PC. Other options for Mac, Linux, and Android are also available. This manual was based on the 2.4 version, though the latest version is 2.8. Multiple versions can be installed and hosted concurrently on your PCs. Sometimes plugins were built on a previous version and doesn’t work on the most recent version.

- Windows QGIS Standalone Installer Version 2.4 (Chugiak) for a 64 bit machine.

Save the file to your computer (will take a few minutes to download), and then double click to follow the installation steps.

Step 2: Open QGIS and start a new project

Click on Start > All Programmes > QGIS Chugiak > QGIS Desktop 2.4.0.

A window with details on a tip will appear, which can be close. A full manual is available on the QGIS’s website, including a short introduction to Geographical Information Systems (GIS) and how to work with QGIS. This manual focus on capturing of wetland boundaries only. The elements of the QGIS layout is given in Figure 1.
Similar to many other GIS software programs, QGIS has a button bars which are docable – they can be moved to your convenience (Figure 2).

Figure 1: Layout of QGIS elements, adapted from [http://docs.qgis.org/2.2/en/docs/training_manual/introduction/overview.html](http://docs.qgis.org/2.2/en/docs/training_manual/introduction/overview.html)

Figure 2: Moving and docking the Layers window in QGIS 2.4.
Take a moment to familiarise yourself with the buttons: hold your cursor over each icon on the button bar (number 2 in Figure 2) until a button tip appears in a yellow call-out box, looking like this: . The horizontal button Toolbars (2) enables functionality to open and save a project as well as edit, zoom, pan and measure features in the Map canvas (3). The vertical Side Toolbar (5) is used to add data and create new layers.

Side/ Vertical Toolbar: Add the data you need using one of the following options:

- Adds vector data such as catchment boundaries and wetland boundaries. Keep the selection on File and press Browse to access the data. You only need to select the .shp file (see Type = SHP file, not XML document). Once the file is selected, press Open.

- Adds raster data, such as the colour orthophotography / SPOT imagery. Keep the selection on File and press Browse to access the data. Once the file is selected, press Open.

- A new shapefile for wetland boundaries, if need be, can be created from the drop-down of the Create Data Layer button on the Side Toolbar. *Although a new shapefile can be created for wetlands data capturing, it would be advised to rather clip the DRDLR-NGI hydrological polygon data to your area of interest and then edit or add to this.

**Step 3: Add data to your project**

The DRDLR-NGI hydrological polygon data for the Wakkerstroom catchment has been clipped and made available for your use in this exercise.

- Add the vector data provided to you in QGIS, including the outline of the sub-quaternary catchment, the wetland polygons, and all other orientation data. Change the symbology of the catchment boundary, for example, by double-clicking on the layer > Click on Simple line > Symbol layer type drop-down > select “Outline: simple line” and press Apply and then OK (Figure 3).
- The colour of the other vector files can be changed accordingly and a percentage transparency assigned.
- Layers can be moved up and down upon preference.
- The layer name can be changed in the Layer Properties under General > Layer name.
- Labels can be activated
- Metadata can be typed under the Metadata tab.
- An ESRI Geodatabase can be added as a Directory option, and all relevant feature classes will then be added to the view.
Images comes in various formats, including *.tiff or *.jpg for example. These can be added as raster layers to the view in QGIS.

OR

You can also stream the NGI 50 cm colour orthos as a Web Map Service (WMS), if you have sufficient data / internet access:

- On the vertical button bar, press Add WMS/WMTS (Figure 4a).
- Select New > and type in “NGI aerial” or a relevant name at the top and add the following URL http://aerial.openstreetmap.org.za/wms-ngi-aerial and press OK (Figure 4b).
- Press Connect in the next window, select the first line of the service and then press Add (Figure 4c).
- It would be best to switch the layer off, zoom to your study area, and then switch in on (Figure 4d).
When adding images, ensure that you select either the JP2 or TIFF file, not the AUX (auxiliary) file.

- Add the Wakker3.tif image from the data.

In QGIS 2.4, the image may not initially appear very clear. You need to enhance the image to make the appearance clearer. This can be done by right-clicking on the image name in the Layer's List table (1) and under the Style option, select the following (Figure 5):
  - Render type = **Multiband color**
  - Contrast enhancement = **Stretch to MinMax**
  - Accuracy = **Actual (slower)**
  - Press **Load** (then wait for the command to be activated and executed)
  - Press **Apply >** and then **OK**

Be very patient, the loading may take some time (took about 5 minutes on a 64 bit PC).

If you have multiple images, consider loading them one at a time, finish the data capturing of that image, and then move on to the next image. This may reduce the amount of imagery that needs to be rendered at a time and improve the speed of displaying imagery and moving around.
Step 4: Install plugins

Most of the steps described in this section, can be performed using a normal installation of QGIS. Additional functionality, like the Autotrace tool, may however, require the installation of Plug-Ins.

The following steps should be followed to install a QGIS Plug-In:

- If you are connected to the internet, you can install the Plug-In in QGIS from online.
- Your PC may require proxy settings to be defined in QGIS: Go to Settings > Options > Network > Enable Use proxy for web access and specify the Host, Port, User and Password, as well as Proxy type based on your IT department’s advice. Press OK.
- Then in QGIS go to Plugins > Manage and Install Plugins… > Not Installed > and click on the selected plugin on the left, and press Install plugin on the bottom right.
- Install (at least) the following plugins:
  - AutoTrace
  - Digitising Tools
- Right-click on an empty space on the button bars and tick on both the Digitizing and Advance Digitizing toolbars.
- Otherwise plugins can also be downloaded directly from http://plugins.qgis.org/plugins/ as zip files. Refer to the latest version of the plugin for downloading.
Step 5: Browsing through the data

The wetland boundaries can be best viewed at a scale of 1:5 000, however digitising is better at a scale of 1:3 000 or even more zoomed in (Figure 6). Use the Pan tool to move around the image, or the mouse’s roll button to zoom in and out.

![Figure 6: Overview of wetland boundaries zoomed to 1:5 000 and 1:3 000 scales.](image)

Step 6: Creating a new layer, copying features and adding an attribute field

When you have absolutely no wetlands data available for a study area you can consider creating a completely new data set from

- **Layer > New > New shapefile layer (Cntrl+shift+N)**

For wetlands this is not always necessary since we can use the NGI hydrological data as a good start.

*A draft data set of the NGI data issued in 2016/03 as a geodb export from Geomedia has been provided to you for use. The data has been cleaned from topological errors, and some NGI FEAT-TYPE classes were crosswalked to HGM types. The work is however still in progress under the National Biodiversity Assessment for 2018 and a final National Freshwater Inventory is still under way.*

Before clipping data, make sure that no records or polygons are selected:

- left-clicking on the layer in the Layer’s List (1)

- Press the button **Deselect Features from All Layers** on the top button bar

The data can then be clipped to a study area:

- **Vector > Geoprocessing Tools > Clip.**

Or just export:

- **Save As > Browse** to a location to save it, type in a file name. **Add saved file to map - press OK.**

For the purpose of this practical exercise, the data has already been clipped to the sub-quaternary catchment boundary [WS_NGI2016_hydro_poly.shp].
If data was captured in Google Earth as a kml, it can easily be copied to an existing shapefile layer. First save the kml as a shapefile, start editing, select the feature and copy it. Then start editing the target layer and paste the polygon. Note that this may result in duplicate polygons, which will require you to delete unnecessary polygons and manipulate the remaining overlapping polygons to avoid duplicate surface areas.

Attribute tables can store various layers of information. In the case of wetlands, the attributes should be as per the Levels of the Classification System. Unnecessary fields / columns can be added and new ones added, for example:

- Right-click on the layer in the table of contents and Open Attribute Table.
- Delete unnecessary fields > start editing > Delete Column (Ctrl+L) > select and press OK
- Add a column > New Column (Ctrl+W) > e.g. “Hydr_reg” for hydrological regime > Select Type = Text (string) and change the width to e.g. 50 characters.

Cross-walking categories from the NGI to a new field “HGM_unit”. The classes ‘vlei’, ‘marshes’ and ‘mudflats’ are for example NGI classes that would require further investigation before they are reclassified as an HGM type:

- Select features using an expression >
- Search under Fields and Values > and create the following SQL query:
  - "HGM_unit" IS NULL AND ( "FEAT_TYPE" = 'Vlei' OR "FEAT_TYPE1" = 'Vlei' )
  - press
  - 50 records are selected of the 105
- Open the Field Calculator, an icon which looks like an abacus
- Make sure that only the selected records will be updated (tick top option)
- Untick “Create a new field” but make sure the “Update existing field” is ticked and the correct field name selected (Figure 7).
- Type ‘(Vlei)’ in the Expression and press OK. The records are updated. Vlei’s are not an acceptable HGM type in the Classification System, however further investigation is required to determine the correct HGM type. Hence we have used brackets to indicate that it is in fact an NGI class, not HGM type.

Figure 7: How to update selected records in the attribute table (QGIS).
Step 7: Capture a polygon

This step guides you to capture a polygon which doesn't need to touch or intersect any other polygon. It provides the first basic step to data capturing. More complicated methods will be illustrated in consecutive steps.

- Left-click once on the shapefile where you want to capture the new polygon.
- Click once on the Toggle Editing button: ![Toggle Editing](Figure 8). The tool will become bevelled and the cursor will change (Figure 8). A pencil will also appear to the left of the layer in the Layer's List.
- Zoom in on the field you want to capture.
- Press the Add Feature button once: ![Add Feature](The tool will become bevelled and the cursor will change (Figure 8)). A pencil will also appear to the left of the layer in the Layer’s List.
- Continue to capture the boundaries of the polygon, ensuring you exclude the roads, and right-click to end. A Feature Attributes dialogue box will appear where the HTM_unit can be filled in. Press OK when completed.
- To save intermediate edits, press the Save Layer Edits button: ![Save Layer Edits](It will turn grey once edits has been saved).
If you want to make any further edits to the wetland boundary, use the Node Tool to add, delete or move a node: . Nodes will turn to red squares which you can then move, right-click and delete: . You can also double-click on the edge (pink line) to add a node.

**Step 8: Deleting a polygon**

Should a polygon have been incorrectly digitised, you can delete it:
- Select the four polygons using one of the options under the *Select Features* options:
- Then press the *Delete* button on your keyboard, or on the button bar: or the cut button: . The buttons will change to colour once you select the polygons.

**Step 9: Reshaping a polygon**

In Figure 7 the full extent of the wetland at Wakkerstroom has not been captured and needs to be extended to the west. The *Reshape Features* tool can easily facilitate this and is available under the *Advanced Digitising* toolbar. It enables faster reshaping of a polygon, compared to the *Node* Tool:
- Toggle the editing on for the layer on which you are digitising.
- Click on the *Reshape Features* button.
- Ensure snapping is set on: *Settings > Snapping Options* . Your cursor will snap to a node as it turned pink.
- Click on the Reshape Features Tool: .
- Start digitising inside or outside the polygon, snap to nodes, left click once and then right-click to end on the same side you started (Figure 9). The polygon will then be reshaped.

![Figure 9: Reshaping a polygon using the Reshape Features tool.](image)
**Step 10: Capturing adjacent polygons**

Very often, different HGM types are located adjacent to one another. It is important that the boundaries between these polygons match perfectly, to avoid duplication of the surface area. A “no overlapping polygons" rule is just one of many rules to ensure the topology of the layer is correct\(^2\). It is important to first set the snapping options for the layer:

- Snapping is the ability of the new nodes that are being captured, to snap to the nodes which are within a certain distance of the cursor.

- In QGIS, go to the menu bar and select *Settings > Snapping Options*:
  - Select only the layer in which you are capturing the wetland boundaries, change the *Tolerance* to 0.001 (map units, or e.g. a number of pixels)
  - tick *Avoid Int.* to the right of the layer
  - Also tick *Enable topological editing* and *Enable snapping on intersection* (Figure 10).
  - Press *Apply* and *OK*.

![Figure 10: Allowing snapping options for capturing adjacent polygons in QGIS.](image)

- Select a wetland where another HGM unit is located adjacent to the one you have captured. Capture a polygon and finish it.
- The adjacent polygon should be started inside the previous polygon and a node created which snap to the edges of the first polygon.

This will result in a polygon layer where the nodes of adjacent polygons snap to one another and no polygons overlap, therefore adhering to topological rules of polygon layers (Figure 11).

Figure 11: Capturing an adjacent HGM unit while ensuring no topological errors (QGIS).

**Step 11: Splitting a polygon**

Sometimes, a riverine wetland is dammed, but the dam wasn’t captured as a separate wetland. Use the split polygon tool to separate it from the main polygon: Select the *Split Features* button on the *Advanced Digitising* toolbar: 

, and digitising from outside the polygon, through the polygon, and ending outside the polygon again with a right-click (Figure 12).

Figure 12: Split a polygon into two or more features in QGIS 2.4.
Step 12: Merging adjacent polygons

You may find that two adjacent polygons captured by the the NGI data, appears to be the same HGM unit, and therefore needs to be merged. Select the two polygons and click on the Merge Selected Features tool on the plugin toolbar: 🔄 (Figure 13).

![Figure 13: Merge Selected Features tool in QGIS 2.4.](image)

Step 13: Using ancillary data to verify HGM types

It is also important to use ancillary data sets to verify the extent and HGM types of the wetlands. The river lines can for instance indicate channel flow. In Figure 14 a 1:500 000 and 1:50 000 river lines shows the wetland drains to the south though no channel is visible on the images for a large portion of the wetland, except in the south. It may therefore be primarily an unchannelle valley-bottom wetland though changing functionality towards the south. Field verification would be required to confirm the HGM type.

Springs can be used to indicate depressions or seepage. Users should verify that these are not groundwater and surface water monitoring boreholes of DWS.
Figure 14: Using ancillary data to verify HTM types in QGIS: (A) river lines to indicate flow and (B) springs to indicate seeps or depressions.

Contour lines or spot heights are also useful as is, for seeing the change in terrain. The 5 m interval contour lines and 1:10 000 spot heights are available from the DRDLR-NGI and can also be interpolated to a Digital Elevation Model (DEM) to calculate slope. Slope can be further used to inform the HGM types. If the data is not available, alternatively the 30 m Shuttle Radar Topography Mapper (SRTM) DEM can be freely downloaded and used.
Step 14. Creating a DEM and calculating slope

It is best to have your data in a projected coordinate system, before you interpolate spot heights and contour lines to a DEM.

If you prefer to use an Albert projection for calculating surface area of wetlands, it is best you create your own customised projection in QGIS:

- Settings > Custom Coordinate Reference System Definition
  - Add new CRS, type in the name, e.g. AEA for South Africa or your study area
  - Then Copy existing CRS from the African Albert projection and change the two parallels to the top and bottom third of the study area, and the unequal longitude running through the study area (Figure 15 as an example of the South African Albers Equal Area prj information).
- Right-click on a layer > Save vector layer as > and select the projected coordinate system from the drop-down options (Figure 15).

![Figure 15: Creating a new coordinate system and saving layers to a new coordinate system in QGIS.](image)

The folder ..\Wakkerstroom\AEAWGS84\ contains the study area boundary, contour lines and spot heights projected to an Albers projection for Wakkerstroom (Central meridian 27°E and -30.33°S and -30.5°S latitude parallels, WGS84).

To create the DEM:

- From the Menu bar, select Raster > Interpolation > Interpolation
- Identify the relief lines as the Input Vector layers, and specify HEIGHT as the Interpolation attribute (Figure 16).
- Press “Add”.
- Add the spot heights too.
- Change the lines to either Break or Structure Lines and keep the points as Type Points.
- Choose either of the Interpolation methods
- The cell size can be left as default values or specified (Figure 16).
Figure 16: Calculating a DEM from contour lines in QGIS.

If the DEM and slope was calculated in ArcGIs and you want to add it to QGIS, double-click on the folder of the grid name, and add the “w001001.adf” file (Figure 17).

Figure 17: Setting symbology for a DEM or slope grid in QGIS.

- The slope classes can be added by pressing “Classify” and changed as you wish.
Step 15. Other useful tools: Tracing an existing polygon

The example below is not wetland related, but shows how the Auto-trace tool can be used to trace a part of a polygon in an existing layer, whether it is the crop fields or a polygon from another layer. The snapping options needs to be set.

- Toggle editing mode on for the layer where you are capturing the data.
- Select the Auto-trace tool from the button bar.
- Left-click on a node in the polygon and move to an opposite node – don’t click yet!
- Hover with your cursor over another node (more-or-less opposite) and then press the SHIFT button on your keyboard. See what happens: a part of the polygon gets automatically highlighted as if it is about to be captured (Figure 18).
- If satisfied, left-click on the second node of choice, while holding in the SHIFT button, and then right-click to end capturing the polygon.
- The original polygon should be deleted in this case, to avoid capturing overlapping polygons (topologically unacceptable).

![Figure 18: Tracing an existing polygon using the Auto-trace tool in QGIS 2.0 (Dufour). The Reshape Features tool is used with the SHIFT button (A) and the user should hover over a node to see which part of the existing polygon will be automatically traced. The result shows the overlap (B); the original polygon should be deleted to avoid duplicate polygons.](image)

Step 16. Calculating surface area and central coordinates

To calculate the central coordinates of the polygon, the following steps should be done using an unprojected shapefile. The coordinate system is therefore in “Geographic”.

- In QGIS, right-click on a shapefile and select Open Attribute Table.
- Press the Toggle editing mode button, or Cntrl+E, to start editing the attribute table.
- Click on the New column button, second from the right, to add a new column.
- An “Add column” dialog box will appear with fields to complete:
  - Insert a Name, e.g Y_coord or X_coord;
  - Change the type to “Decimal number (real)";
- Specify the Width as “20” and change the Precision to “5”. These specifications will result in a column width allowing 20 digital numbers to be recorded of which the last 5 will be for decimals.

- From the menu bar, select Vector > Analysis Tools > Mean coordinate(s).

- A dialog box will appear; make the following changes:
  - Input vector layer: select the shapefile you are using;
  - Do not change the Weight field.
  - You can specify a Unique ID field, should this have been calculated for the polygon shapefile.
  - Define the Output shapefile name and location. Unfortunately QGIS does not allow the attributes to be populated within the polygon shapefile.
  - Click OK.

- You will be prompted by the software, asking whether you want to add the new shapefile to the view. Select Yes, and then close the original dialog box.

- Open the Attribute Table of the new shapefile. You will notice that three field were calculated: a MEAN_X, MEAN_Y and UID field.

- Use the UID field to relate it back to the original polygon layer by merging the tables and saving it as a new shapefile.

To calculate surface area, the shapefile must be projected to a coordinate system in which metres can be measured.

**Step 17. Checking and correcting topology**

It is always best to check the topology of a layer, particularly when you have received it from someone else, but also when you have finished data capturing. Errors should be reported directly to the data custodian, so if you have received the data from the NGI directly, topological errors should be reported to them.

The Topology Checker tool can be activated by either clicking the second last tool on the vertical button bar, or through the menu bar > Vector > Topology Checker > TopologyChecker (Figure 19).

![Figure 19: Activating the topology checker in QGIS.](image)

- In the TopologyChecker, select Configure
- Identify the layer as the wetlands layer and select the rule “must not overlap”
• Add Rule and press OK
• Press Validate All (Show errors should also be ticked).

The NGI data for the Wakkerstroom areas has been cleaned and show no overlapping polygons.

An overlapping polygon was then digitised on purpose and the exercise repeated. The error is detected and listed on the right, while highlighted in red in the view (Figure 20).

![Topological error detected in QGIS.](image)

Figure 20: Topological error detected in QGIS.

Any errors should be addressed and the checker rerun to ensure no errors is present.

**Step 18. Making a map**

A map layout with a legend and scale bar can be made for a report:
• On the menu bar, select Project > New Print Composer (Ctrl+P)
• Select the Add new map button (Figure 21), and draw a box on the layout.
• Map elements can be added from the Layout menu or the buttons on the right
CONCLUSION

This manual provided a short overview on how to capture wetland boundaries as polygons in Quantum GIS 2.4. Should you require any additional assistance, please refer to the online help of QGIS or ArcGIS, look up short video clips on YouTube that demonstrate the tool, or contact the CSIR through your programme manager for further assistance.

The following links and contacts can be helpful:

- The [www.sanbi.org/nba](http://www.sanbi.org/nba) website provides an overview of the National Biodiversity Assessment for 2018 (NBA2018).
- The [http://gsdi.geoportal.csir.co.za/projects/national-biodiversity-assessment-of-2018](http://gsdi.geoportal.csir.co.za/projects/national-biodiversity-assessment-of-2018) website provides an overview of the Freshwater Component and a link to a data viewer where the data can be viewer. The site and viewer will continuously be updated. We hope to make all the draft data downloadable from the website by 1 Aug 2016. This will be a temporary site for the duration of the project. Final data layers will be available through SANBI’s BGIS website.
- Heidi van Deventer ([HvDeventer@csir.co.za](mailto:HvDeventer@csir.co.za)) can be contacted for more information on the Freshwater Component of the National Biodiversity.
- Namhla Mbona ([N.Mbona@sanbi.org.za](mailto:N.Mbona@sanbi.org.za)) should be contacted for more information on the National Wetland Map.
- Leolin Qegu ([LQegu@csir.co.za](mailto:LQegu@csir.co.za)) should be contacted if you pick up any major errors in the data. Errors can be reported, with the coordinates and proposed corrections, until 28 Feb 2017.